The current version of Aether requires OS X 10.9 Mavericks or later, running on a 64-bit Intel-based Mac. Older versions of Aether are available for download for those using older versions of OS X as well as those using PowerPC Macs. Please note that these old versions are made available for download in the hopes that they're useful, but I cannot provide any technical support for them, as they are obsolete.

Older versions:

macOS Version Latest Supported Version of Aether
Mac OS X 10.4 Tiger (Intel & PPC) 1.5.12 (284)
Mac OS X 10.5 Leopard (Intel & PPC) 1.5.12 (284)
Mac OS X 10.6 Snow Leopard 1.5.14 (292)
OS X 10.7 Lion 1.6.4 (1557)
OS X 10.8 Mountain Lion 1.6.4 (1557)

As always, if you have any questions, please feel free to email me.